IE8 / IE9 (or older)

We do not support IE9 or older. Using a browser this old is entirely at your risk and may result in unexpected behaviour.

IE8/9 are both extremely old and outdated. It is generally considered to be very insecure and is no longer supported by Microsoft.

You should either upgrade your browser immediately or speak to your IT department about having them upgrade it for you.


If this isn't possible, consider keeping IE and also installing the latest version of Chrome to access Concierge. 


IE10

IE10 is also end of life (see here)

https://www.microsoft.com/en-gb/windowsforbusiness/end-of-ie-support

We will support IE10 until June 30 2018.

After this time you will need to upgrdae to IE11 or another more modern browser.


Why can't you support all browsers forever?

Each major version of browser that we support costs us a lot of time. As time goes on this burden is greater and greater, there are also potential security risks. So that we can focus on building the best apps we can we only support more recent released of browsers.


Reccomended browser

We reccomend running the latest version of Chrome, it's fast and secure.